Can't update datalayer with python RPC

I’ve been trying to get basic datalayer functionality working for my python app and I can’t seem to get any methods with the store ID to work. I can update via cli no problem, and I can use create_data_store, and some other methods without issue.

I think this code should work, but it isn’t. I’ve tried everything I can think of, I don’t know what I’m doing wrong.

		dl = await DataLayerRpcClient.create('localhost', uint16(self.datalayer_rpc_port), DEFAULT_ROOT_PATH, self.chia_config)
		update_status = await dl.update_data_store(
				store_id=hexstr_to_bytes("7bef9852cb12ec571ccc879d7ed045eaaf20d76ef002bf5e899db18d3c7e1bec"),
				changelist=[{"action":"insert", "key":"0001", "value":"abcde"}],
				fee=0
		)
		print(f"status: {update_status}")
		dl.close()

This is the error

   File "C:\Users\gaerax\git\Spriggan\datalayer\connector.py", line 51, in __publish_game
     update_status = await dl.update_data_store(
   File "C:\Users\gaerax\anaconda3\envs\sprig\lib\site-packages\chia\rpc\data_layer_rpc_client.py", line 23, in update_data_store
     response = await self.fetch("batch_update", {"id": store_id.hex(), "changelist": changelist, "fee": fee})
   File "C:\Users\gaerax\anaconda3\envs\sprig\lib\site-packages\chia\rpc\rpc_client.py", line 49, in fetch
     raise ValueError(res_json)
 ValueError: {'error': 'non-hexadecimal number found in fromhex() arg at position 5', 'success': False}

Oh, I actually just figured out that the issue is not the store_id, it’s the “value” in the changelist.

I changed it to just “ab” randomly and it worked all of a sudden.

I guess the key and value values are supposed to be bytes? I didn’t realize that… I’m dumb, I’ll leave this here incase anyone else makes the same mistake.