Chia wallet split coins, does it work?

Running Chia 1.8.1 in wallet mode on Testnet

chia wallet show
Wallet height: 2767877
Sync status: Synced

chia wallet coins split -i 1 -n 1 -a .01 -t 0x2fxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

Exception from ‘wallet’ {‘error’: ‘Wallet needs to be fully synced before sending transactions’, ‘success’: False}:
Traceback (most recent call last):
File “chia/cmds/”, line 116, in get_any_service_client
File “chia/cmds/”, line 235, in execute_with_wallet
File “chia/cmds/”, line 219, in async_split
File “chia/rpc/”, line 214, in send_transaction_multi
File “chia/rpc/”, line 61, in fetch
ValueError: {‘error’: ‘Wallet needs to be fully synced before sending transactions’, ‘success’: False}

If I try to create 100+ coins it hangs for several seconds before giving the error, and the wallet shows a height a few blocks back before immediately resyncing again.

If I try to create 1 new coin, it hangs for less time, and is less far behind when it resyncs.

Basically, I am looking at the use case of if I get one large coin and I want to make 10 smaller offers from it, I need to “make change” on the coin 10 separate times, waiting for each change to be confirmed on the blockchain before making the next set of change.

Does anyone know how to make split work correctly?

I just confirmed that this command works, with a full node and with a light wallet only. Something is causing your wallet to fall out of sync when you run this command. This will require some troubleshooting, which will be much easier in a real-time chat. If you’re on Discord, I recommend you post this question in the #support channel.

They are helping me in discord, but I am also replying here for searchability. Since posting in discord, a few others have chimed in that they are also having errors when splitting coins.

To add a bit more to this:

Testnet 1.7.1 Light Wallet - Splits OK
Testnet 1.8.1 Light Wallet - Fails to split
Main 1.8.1 Full Node - Splits OK

When you confirmed that it worked with light wallet only, can you confirm that you were on 1.8.1 without a full node running?

Was thinking of just moving back to the 1.7.1 version for my tests on the splits, but it is showing incorrect balances even after nuking the wallet and resyncing… just can’t seem to win.

My apologies, I just tried again on 1.8.2rc3 and can reproduce your issue with a light wallet only. Yesterday when I tried this, it’s possible that my node was still considered synced even though I had switched to the light wallet.

This appears to be a regression. Thanks for pointing it out!

I’m trying to reproduce this with logs, and in the process I created a new wallet, sent it one coin, attempted to split it. This time it worked. (This likely why I reported that it had worked yesterday.) This could end up being a tricky issue to debug. If you have anything interesting in your logs, we would appreciate it if you could post here or in Discord.