Errors using the CAT-admin -tool

I’m trying to setup an environment for minting CATs on my Mac M1.

Single Issuance Chia Asset Token (CAT) | Chialisp
I watched this video from Chia’s YouTube channel as a starting point:

But I run into an issue making this call in the CAT-admin-tool:

cats -l CAT-admin-tool/reference_tails/genesis_by_coin_id.clsp.hex --solution ‘()’ --send-to MYRECEIVEWALLET -a 0 -f 0 -b --select-coin

That looks like this:

/CAT-admin-tool/venv/lib/python3.9/site-packages/chia/cmds/wallet_funcs.py", line 548, in get_wallet
print(f"Error: {log_in_response[error]}")

Someone on YouTube posted a similar issue, and suggested that they fixed it, by running the light wallet in addition to the full node.

I think it’s my dev environment, which I’m wondering if someone can help me understand.

  1. I setup, ran and synched the Chia light wallet (beta 1.3)

  2. I setup Chia Dev Tools
    using the script on the Readme

python3 -m venv venv
. ./venv/bin/activate
pip install chia-dev-tools
cdv —version

  1. I setup CAT Admin Tool

using the script on the Readme

git clone GitHub - Chia-Network/CAT-admin-tool: Admin tool for issuing CATs
cd CAT-admin-tool
python3 -m venv venv
. ./venv/bin/activate
python -m pip install --upgrade pip setuptools wheel
pip install .

And, as you might have guessed, the second script made it impossible to run the Chia Dev Tools in the first script. My guess is both scripts create their own instances, inside the virtual environment (venv) that can’t talk to each other.

So, I think I need a better way to set everything up.

Right now, I’m waiting for my full node to sync but I’m going to try running a full node AND the beta 1.3 at the same time somehow.

Another possible issue; I have a full node on the same WIFI network, but it’s farming, and could be getting in my way.

Thanks so much for any ideas you might have!

1 Like

The light wallet and the full node don’t conflict so you can run them at the same time. In fact with the latest version of the CAT admin tool, you don’t even need the node. CDV is broken right now with the 1.3 beta, so I would suggest installing it in a different venv until there’s a new release. But yeah, it looks like the error you are getting is from not having a running wallet from where you are running the CAT commands. Make sure you can run chia wallet show, if that works, the CAT-admin-tool should work.

1 Like